Welcome to Working With Rails


Discussion Forums

Discuss all things Ruby on Rails with perhaps the web's most vibrant group of Ruby on Rails enthusiasts.
problems installing subtruct
4 Posts
problems installing subtruct

Im very new to ruby and I'm facing huge problems installing substruct in windows vista.I followed the instructions in the site http://code.google.com/p/substruct/wiki/InstallingSubstruct

I created the tables as told using a gui mysql software called navicat.And when i tried to entered rake substruct:db:bootstrap

it shows an error

C:\Ruby\projekt\substruct>rake substruct:db:bootstrap

(in C:/Ruby/projekt/substruct) Checking requirements... Initializing database... [SUBSTRUCT WARNING] Mail server settings have not been initialized. Check to make sure they've been set in the admin panel. Couldn't drop substruct_development : # C:/Ruby/projekt/substruct/vendor/rails/activesupport/lib/active_support/dependen cies.rb:116: [BUG] Segmentation fault ruby 1.8.6 (2008-08-11) [i386-mswin32]

This application has requested the Runtime to terminate it in an unusual way. Please contact the application's support team for more information.

When i check the query.No tables have been created.I tried saving the query by copying and pasting from the schema.rb file .but still nothin worked .

this is wat i get

mysql> use substruct_development Database changed mysql> select * from schema; ERROR 1064 (42000): You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'schema' at line 1

or is it a problem with my database.yml file:

"socket: /tmp/mysql.sock"

Ive been trying everything to make this work.Ive gone so many sites trying to correct these errors. But nothing seem to work.It would be really grateful if somebody could help me out in this please. Thankyou

Is your mysql database for substruct running on localhost? If so (which it probably is), remove the the socket line from the database.yml and make sure you have "host: localhost"

Have you Modified your database.yml ? Is your database name substruct_development?

I think thats the problem. You dont really need to create stuff with hand, Running bootstrap will create the tables and load default data in the db.

You need to format your database.yml like this development: adapter: mysql database: myprojectname_development username: devrailsuser password: devrailspassword host: localhost

4 Posts
Login to add your message