Welcome to Working With Rails


Discussion Forums

Discuss all things Ruby on Rails with perhaps the web's most vibrant group of Ruby on Rails enthusiasts.
Rails JSR286 portlets
2 Posts
Rails JSR286 portlets


I created rails application and when i tried to build portlets i was getting an error . Please see my steps

srinath@srinath-laptop:~$ rails example srinath@srinath-laptop:~$ cd example/ srinath@srinath-laptop:~/example$ ls app db lib public README test vendor config doc log Rakefile script tmp

srinath@srinath-laptop:~/example$ caterpillar portlets /usr/local/lib/site_ruby/1.8/rubygems.rb:149:in activate': can't activate activesupport (= 2.0.2, runtime), already activated activesupport-2.3.3 (Gem::Exception) from /usr/local/lib/site_ruby/1.8/rubygems.rb:49:ingem' from /home/srinath/.gem/ruby/1.8/gems/caterpillar-1.0.1/lib/caterpillar.rb:50 from /home/srinath/.gem/ruby/1.8/gems/caterpillar-1.0.1/lib/caterpillar.rb:47:in each' from /home/srinath/.gem/ruby/1.8/gems/caterpillar-1.0.1/lib/caterpillar.rb:47 from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:31:in gem_original_require' from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:

I installed caterpillar gem and also have rails 2.3.3, 2.1.2, 2.0.2...

Could any one help me on this ..

You have a dependency problem with the Rails gems. Something is trying to load ActiveSupport version 2.0.2 after ActiveSupport version 2.3.3 has already been loaded. Since it looks like it's not your code that's making the assumption, the easiest way to fix this is most likely to uninstall all versions of Rails except for the one you want to use (2.3.3, presumably).

Uninstalling Rails is a bit of a pain, since you have to remove each gem individually. You can do this:

%> gem list active
%> gem list action
%> gem list rails

and then remove anything that's not version 2.3.3, e.g.:

%> sudo gem uninstall activesupport --version 2.0.2
2 Posts
Login to add your message