I created rails application and when i tried to build portlets i was getting an error . Please see my steps
srinath@srinath-laptop:~$ rails example srinath@srinath-laptop:~$ cd example/ srinath@srinath-laptop:~/example$ ls app db lib public README test vendor config doc log Rakefile script tmp
srinath@srinath-laptop:~/example$ caterpillar portlets
activate activesupport (= 2.0.2, runtime), already activated
I installed caterpillar gem and also have rails 2.3.3, 2.1.2, 2.0.2...
Could any one help me on this ..
You have a dependency problem with the Rails gems. Something is trying to load ActiveSupport version 2.0.2 after ActiveSupport version 2.3.3 has already been loaded. Since it looks like it's not your code that's making the assumption, the easiest way to fix this is most likely to uninstall all versions of Rails except for the one you want to use (2.3.3, presumably).
Uninstalling Rails is a bit of a pain, since you have to remove each gem individually. You can do this:
%> gem list active %> gem list action %> gem list rails
and then remove anything that's not version 2.3.3, e.g.:
%> sudo gem uninstall activesupport --version 2.0.2