Welcome to Working With Rails

 

Discussion Forums

Discuss all things Ruby on Rails with perhaps the web's most vibrant group of Ruby on Rails enthusiasts.
Error with mysql gem installation
8 Posts
Error with mysql gem installation

have you installed bundler yet ! check if this helps, http://techleap.blogspot.com/2010/11/not-able-to-create-database-mysql-and.html

@ Tanmay Golhar

Hey you are partially right. Actually with rails 2.2 the default mysql gem is not compatible corresponding to the mysql5.1

for that you need to get the latest * libmysql.dll* file from the net and put that file into the /ruby/bin directory then your rake db:migrate command will work properly.....

Thanks Adam, what u suggested worked for me... Apparently, rails is not compatible with MySQL 5.1. So I had to copy MySQL 5.0's libmysql.dll to my ruby /bin and it worked. and it also solved this problem "Segmentation Fault":http://www.workingwithrails.com/forums/4/topics/744-segmentation-fault

This worked for me. It happened when I had uninstalled and reinstalled a variety of ruby and rails and instant rails installations on windows XP. how to edit path can be found at http://vlaurie.com/computers2/Articles/environment.htm#editing

Hm. I don't know much about installing MySQL on Windows. The most common problem I've seen with installing the mysql gem is that you're missing the development libraries for MySQL. But, your install appears to have succeeded, which makes it appear as if it found the libraries successfully. I looked around quickly and found one post saying that you'll run into problems if libmysql.dll isn't in your path. You could try adding that to your path and see if that works.

THNX FOR REPLYING ADAM hey did the gem installation in the way you suggested...so the error message arent there....but still aftr doin this...when i try doing rake db:migrate to migrate the tables to mysql datbase it again gives me the following error

rake db:migrate (in C:/Documents and Settings/mpenta/My Documents/Aptana Studio/demo) !!! The bundled mysql.rb driver has been removed from Rails 2.2. Please install the mysql gem and try again: gem install mysql. rake aborted! 126: The specified module could not be found. – C:/ruby/lib/ruby/gems/1.8/gems/mysql-2.7.3-x86-mswin32/ext/mysql.so

...

,..... I MEAN THE SAME ERROR...DONT KNOW WATS WRONG...?????????

It looks like the gem installed correctly, you just ran into errors with the documentation. You should be able to proceed, but if you'd like the errors to go away you can do this:

gem install mysql --no-ri --no-rdoc

Initially when i did rake db:migrate(or performed any operation related to mysql database) I got the following error----------

rake db:migrate (in C:/Documents and Settings/mpenta/My Documents/Aptana Studio/demo) !!! The bundled mysql.rb driver has been removed from Rails 2.2. Please install the mysql gem and try again: gem install mysql. rake aborted! 126: The specified module could not be found. - C:/ruby/lib/ruby/gems/1.8/gems/mysql-2.7.3-x86-mswin32/ext/mysql.so

(See full trace by running task with --trace)

SO THEN I TRIED INSTALLING MYSQL GEM ---- BUT WHEN I DID "gem install mysql" I GOT THE FOLLOWING ERROR REPEATEDLY...

gem install mysql Successfully installed mysql-2.7.3-x86-mswin32 1 gem installed Installing ri documentation for mysql-2.7.3-x86-mswin32... Installing RDoc documentation for mysql-2.7.3-x86-mswin32... ERROR: While generating documentation for mysql-2.7.3-x86-mswin32 ... MESSAGE: Unhandled special: Special: type=17, text="<!-- $Id: README.html,v 1.20 2006-12-20 05:31:52 tommy Exp $ -->" ... RDOC args: --op C:/ruby/lib/ruby/gems/1.8/doc/mysql-2.7.3-x86-mswin32/rdoc --exclude ext --main README --quiet ext README docs/README.html (continuing with the rest of the installation)

I CANNOT PROCEED FURTHER DUE THESE ERRORs--- CAN NYONE PLEASE HELP ME WITH THIS...

8 Posts
Login to add your message