Welcome to Working With Rails

 

Discussion Forums

Discuss all things Ruby on Rails with perhaps the web's most vibrant group of Ruby on Rails enthusiasts.
Error installing bleak_house
3 Posts
Error installing bleak_house

Depending on which Ruby distribution you are using (cygwin, mingw, or most likely the native windows binary), you will need to set up some compiler tools if you REALLY want that gem to run on Windows. For such "native-compiled" gems, most people find it's much easier to just find a Linux box to deploy on.

For native windows, I think MSVC6 (Visual Studio 6 I think -- it's quite old) is still the compiler used for the builds, as the more recent compilers target .NET's Common Language Runtime.

If you have MSVC6 and nmake.exe (a third-party make tool) installed, there is a command-line icon in your Visual Studio start menu that will set up the compiler environment. You can then do a "gem install " from within this command-line shell, and get much further along.

Be warned, though, some less-polished gems are UNIX/Linux specific, and just don't have build rules for Windows environments. If you encounter such a gem, and really need it, you'll need to get a Linux box.

All I can say to this is that Windows cannot utilize "Makefile" (this is a Linux compilation routine) so that's probably why the gem build errors. Some gems I have installed on Windows have generated errors like this but still work to a degree, although that's rarely the case. Most likely this gem will result in unexpected behavior even if it works partially. You should try to find some Windows specific docs for this gem to see if there are alternative versions or techniques for installing it.

Not being able to follow along with online docs or get every gem/plugin working 100% is one of the main reasons I'm making the switch to a Mac. Also I want to be Mac/GIT savvy when I head out into the Rails wild.

I am trying to install bleak_house

I am using ruby 1.8.6 Rails 1.2.5 On Windows 2000

I downloaded the gem files from net and while executing them I got the following response

D:\Projects\webshop>gem install bleak_house-3.7.1.gem ERROR: While executing gem ... (RuntimeError)

Error instaling bleak_house-3.7.1.gem:
    bleak_house requires ccsv >= 0.1

For this i downloaded ccsv-0.1 gem, but ended up in a new error

D:\Projects\webshop>gem install ccsv-0.1.gem Building native extensions. This could take a while... ERROR: While executing gem ... (RuntimeError)

Error instaling ccsv-0.1.gem:
    ERROR: Failed to build gem native extension.

ruby extconf.rb install ccsv-0.1.gem creating Makefile

nmake 'nmake' is not recognized as an internal or external command, operable program or batch file.

Gem files will remain installed in c:/ruby/lib/ruby/gems/1.8/gems/ccsv-0.1 for i nspection. Results logged to c:/ruby/lib/ruby/gems/1.8/gems/ccsv-0.1/ext/gem_make.out

Any clue on this :(

Person
Forum Rating: 100
Sign In To Rate Post
3 Posts
Login to add your message