Welcome to Working With Rails

 

Discussion Forums

Discuss all things Ruby on Rails with perhaps the web's most vibrant group of Ruby on Rails enthusiasts.
9 Posts
mySQL problems

I have been trying to get things up and running, and have been running into some problems which I haven't seen before. I am using InstantRails and the RadRails Plugin with the Aptana IDE. Also, I am using HeidiSQL to manage my SQL databases. Everything seems set up fine, and have run a few other projects in development environments successfully, but recently things have gone sour.

Recently, I have been trying to set up a LovdbyLess project, and have followed the directions to the T, but to no avail!

All the files have been moved into my project directory, and I have no errors. I have installed all the required ruby gems, and rake tests pass with flying colors, doing all tests, assertions, with absolutely no errors or failures.

Whenever I try to run the project, my console output is as such:

=> Booting Mongrel (use 'script/server webrick' to force WEBrick) => Rails application starting on http://0.0.0.0:3000 => Call with -d to detach => Ctrl-C to shutdown server Starting Mongrel listening at 0.0.0.0:3000 Starting Rails with development environment... -e: No such file or directory - uname WARNING: You're using the Ruby-based MySQL library that ships with Rails. This library is not suited for production. Please install the C-based MySQL library instead (gem install mysql). [4;36;1mSQL (0.004000)[0m [0;1mSET SQL_AUTO_IS_NULL=0[0m Rails loaded. Loading any Rails specific GemPlugins Signals ready. INT => stop (no restart). Mongrel 1.1.4 available at 0.0.0.0:3000 ** Use CTRL-C to stop.

I tried messing with a few things to get it to work, but no matter what, it always tells me I am using the Ruby-based MySQL library... Also, in order to combat the problem, I uninstalled the SQLite gem. My local list of gems tells me mysql is installed, but I tried to gem install mysql multiple times anyway, and it gives me this error:

C:\InstantRails\rails_apps\myapp>gem install mysql-2.7.3-mswin32.gem

Successfully installed mysql-2.7.3-mswin32... Installing ri documentation for mysql-2.7.3-mswin32... Installing RDoc documentation for mysql-2.7.3-mswin32... While generating documentation for mysql-2.7.3-mswin32 ... MESSAGE: Unhandled special: Special: type=17, text="<!-- $Id: README.html, v 1.20 2006-12-20 05:31:52 tommy Exp $ -->" ... RDOC args: --op c:/ruby/lib/ruby/gems/1.8/doc/mysql-2.7.3-mswin32/ rdoc --exclude ext --main README --quiet ext README docs/README.html (continuing with the rest of the installation)

C:\InstantRails\rails_apps\myapp>

And even though the Mongrel server starts, when I try to browse to http://localhost:3000, it kind of works, but will only display the "Welcome aboard You’re riding Ruby on Rails!" page. I have updated, cleaned, reinstalled all gems, nothing works!

I am definitely a newbie at this, but I usually am able to work problems out on my own; however, I seem to have met my match. Any advice on this situation, or on running LovdbyLess, would be so so so much appreciated!

-Dave S.

The mysql error you are seeing there isn't an error telling you that you can't use the software or that it isn't going to work, simply that it is not suited for production. I would hazard a guess that many Rails developers will also see this message developing from a standard machine. If you've reached the point where you see CTRL-C to stop, your server has booted, and the fact that you've seeing the "welcome" message means its all working. You might need to read some more about how to use LovdbyLess project. Look at your routes.rb file (found in your config directory) and see what it has in there. Make sure you have the application routes in place, then remove index.html from your public directory and see what happens.

Also, another indication is that if your tests are passing your database appears to have been successfully setup (at least your test database) which means that you're not actually having mysql errors, rather you are just being warned that your machine is not suited for production.

Hope that helps, let us know if there is something deeper to the problem. I haven't personally played with the LovdbyLess package, but have thought about taking a look at it. Good luck!

So I ended up playing with a few more settings, the routes.rb file was fine, it was in the global_variables.rb in config\initializers\ where it specified RAILS_ENV as "production" instead of "development." Also, I alwayyyys forget to remove the index.html file from public. Once I did that, the root works, and a few other pages, but when I try and register a new user, it gives me this:

DRb::DRbConnError in AccountsController#signup

druby://localhost:10005 - #

RAILS_ROOT: C:/InstantRails/rails_apps/orijinsb Application Trace | Framework Trace | Full Trace

C:/InstantRails/ruby/lib/ruby/1.8/drb/drb.rb:736:in open' C:/InstantRails/ruby/lib/ruby/1.8/drb/drb.rb:729:ineach' C:/InstantRails/ruby/lib/ruby/1.8/drb/drb.rb:729:in open' C:/InstantRails/ruby/lib/ruby/1.8/drb/drb.rb:1189:ininitialize' C:/InstantRails/ruby/lib/ruby/1.8/drb/drb.rb:1169:in new' C:/InstantRails/ruby/lib/ruby/1.8/drb/drb.rb:1169:inopen' C:/InstantRails/ruby/lib/ruby/1.8/drb/drb.rb:1085:in method_missing' C:/InstantRails/ruby/lib/ruby/1.8/drb/drb.rb:1103:inwith_friend' C:/InstantRails/ruby/lib/ruby/1.8/drb/drb.rb:1084:in method_missing' C:/InstantRails/ruby/lib/ruby/gems/1.8/gems/acts_as_ferret-0.4.3/lib/remote_index.rb:31:in<{"password_confirmation"=>"password", "captcha_answer"=>"9991212a6998c84bb3dc86eccb30020637bec189", "captcha"=>"25", "terms_of_service"=>"1", "login"=>"dswoff99", "password"=>"password", "email"=>"dswoff99@bu.edu"}, "commit"=>"Sign-up Now"}

No clue... Also, thanks so much for the previous help. Any thoughts?

Have you installed the will_paginate Rails plugin already?

Hey David,

Gad you have started to play around with our social networking application. The uname error you are getting as well as the drb error seem to be coming from acts_as_ferret on windows. see: http://groups.google.com/group/lovdbyless/browse_thread/thread/ee52f22b3a1dbf28/12026b33ca3dd10b?lnk=gst&q=uname#12026b33ca3dd10b

You should join our group so you can get some up to date info from project developers and others who have been using the same project.

-- Matthew Peychich (8Mile)

Thank you so much for all the help everyone!

So far, I have been able to play with a few of the files and stuff, and have really learned so much, and gotten more working. I can now register users, and have registered one, and altered the db entry to make it an admin. I still have the uname error and the problem of using the Ruby-based server. Matt V, does that mean I need to upgrade mySQL again or what? I don't understand...

Matt P, thanks for the link, that sounds great.

again thanks all!

Dave,

No, I really don't think this issue is anything you need to worry about, or even really an issue at all. As I was saying before if Rails is currently interacting with mySql and you're not having any problems with the tests than you're okay, I wouldn't loose any sleep over it. That message is just trying to tell you that your machine is not really suited to host from.

One question to clarify, you aren't actually thinking of hosting from your windows machine are you?

Anyway, I wouldn't worry about the mysql error, the only thing that has me curious is the -e uname that was at the beginning of the warning, was that a parameter you passed yourself?

I forgot to mention that the MESSAGE: Unhandled you received while installed the mysql gem on your machine is normal for the Windows OS.

On a sidenote, that's a pretty wicked error message right there:

"druby://localhost:10005 – #"

9 Posts
Login to add your message